Outbacker RV Forum banner
1 - 4 of 4 Posts

·
Outbackers Contributor
Joined
·
1,877 Posts
Discussion Starter · #1 ·
I have had my new Outback for a couple of weeks now and keep finding spiders everywhere. They are not the normal NY type so I am assuming they were in the TT when manufactured. Anyone else notice these brown creatures or am I just the lucky one.

So far loving the new rig, 6 volt battery mod is tonight.

Happy camping! sunny

Kevin
 

·
Outbackers Contributor
Joined
·
617 Posts
Hi Kevin,
We haven't had any spiders in our TT, but did with our pop-up.
In the pop-up and now in the TT I use "Ant Traps". They work great!
I put them under the sinks, in the pantry, etc.... Anywhere dog and child can't get to them. I think "RAID" makes them and you can find them where the bug spray is sold. Hope this helps!

Have a great day! sunny
 

·
Outbackers Contributor
Joined
·
4,740 Posts
No spiders here...probably the cold weather. I bet they jumped off the OUTBACK on delivery to the dealer here!


I did the 2-6 volt mod last season. Now I want to get the battery boxes in next.
 

·
Outbackers Contributor
Joined
·
1,877 Posts
Discussion Starter · #4 ·
Jolly,

I put my batteries in boxes, just didn't use any lids. I thought the boxes might help prevent any damage if stones manage to fly up in there. I like the idea of no lids, that way it is faster to check the fluid level. I drilled holes in the box bottom for any water that may get in there.

Have a good weekend

Kevin
 
1 - 4 of 4 Posts
Top